TasaseloW

TasaseloW-ohjelma on tarkoitettu tasaselo-periaatteiden mukaisen turnauksen apuvälineeksi.

Ohjelma on tehty Visual Basic -kielellä.

Kehitysvälineenä on käytetty alun perin VisualStudio Express 2013 tuotetta,

mutta viimeisin kehitysympäristö on VisualStudio 2022.

Ohjeet on konvertoitu tuotteelle HelpnDoc vuonna 2023.

Ohje jakaantuu neljään osaan:

1. Turnauksen perustoiminnot

2. Kierroskohtaiset toimenpiteet

3. Korjaus- ja muut erityistoimet sekä lopputulosten muodostaminen

4. Ohjeita erikoistilanteisiin

Ohjelman eri osioiden välillä siirrrytään valitsemalla alkusivulta haluttu aihe ja painamalla Jatka-painiketta.

Copyright © <Dates> by <Authors>. All Rights Reserved.


Perustoimet

TasaseloW ››

Perustoimiin kuuluvat turnauksen perustietojen antaminen, pelaajatietojen ilmoittaminen,

turnauksen tiedostojen muodostaminen ja alustus, ohjelman parametrien antaminen

sekä ryhmäkokojen ilmoittaminen.

Ohjelman parametritietoja ja ryhmien kokoja voidaan muuttaa turnauksen aikana.


Perustiedot

TasaseloW ›› Perustoimet ››

Turnaus yksilöidään kolmimerkkisellä tunnuksella. Tunnusta käytetään turnauksen tiedostojen nimissä loppuliitteenä.

Otsikko-teksti tulostuu mukaan kaikkiin tulosteisiin.

Suositus on, että otsikkoon annettaisiin järjestävän seuran lyhenne, kilpailun pitopaikka ja päivämäärä,

useamman päivän kilpailussa myös alkupäivä, Otsikolle on varattu tilaa 50 merkkiä.

Kierrosmäärä vaikuttaa turnaustiedostojen alustukseen, ja se saa olla suurempi kuin turnauksessa pelattavaksi aiottu kierrosmäärä.

Turnaus voidaan lopettaa minkä tahansa kierroksen jälkeen. Suositus on kuitenkin, että perustiedoissa ilmoitetaan kilpailun oikea

kierrosmäärä. Kilpailuun voidaan tarvittaessa lisätä uusia kierroksia yksi kerrallaan.

Turnauksen hakemiston oletusarvo on C:\muuselo3, mutta sen voi vaihtaa haluamakseen. Hakemistomäärittely talletetaan

ohjelmallisesti siihen hakemistoon, mistä TasaseloW-ohjelma on käynnistetty. Seuraavalla kerralla ohjelmaa käynnistettäessä

hakemistomäärittely haetaan tiedostosta tasaselow.ini.

Jos uusi turnaus halutaan tallettaa toiseen hakemistoon, on määrittelyä muutettava vastaavasti.

Turnauksen tiedostot voidaan määritellä talletettavaksi mihin tahansa hakemistoon, joka voi sijaita esimerkiksi muistitikulla.

(Jos halutaan ajaa kahta eri turnausta yhtä aikaa, pitää tasaselow.exe käynnistää toistamiseen, ja tällöin turnaustiedostojen

on sijaittava yhteisessä hakemistossa. Jos halutaan, että hakemistotkin ovat erilliset, on tasaselow.exe, tataselo.chm ja selolist.txt

kopioitava mukaan näihin molempiin erillisiin hakemistoihin.)


Ilmoittautuminen

TasaseloW ›› Perustoimet ››

Ohjelman tarvitsemat pelaajatiedot voidaan muodostaa kolmella tavalla.

1. Pelaajatiedot kopioidaan jostain olemassa olevasta TasaseloW-ohjelman käyttämästä pelaajatiedostosta.

Tämä menettely on lähinnä testaustilanteita varten.

2. Pelaajatiedot haetaan Selolistalta. Tämä on suositeltavin tapa pelaajatietojen rekisteröimiseksi.

3. Pelaajatiedot kysellään yksitellen.Tämä tapa tulee kyseeseen silloin, kun pelaajaa ei ole Selolistalla.

Tapoja kaksi ja kolme voidaan suorittaa vuoron perään samaan rekisteröintiin liittyen.

Pelaajatiedostoista tehtävä listaus muodostetaan kahdella eri tavalla sen mukaan, onko turnauksen kaikki tiedostot

jo perustettu vai ei. Jos turnaustiedostoja ei ole perustettu, tehdään listaus PELAAJAT-tiedostosta, muutoin PERUS-tiedostosta.

PELAAJAT-tiedostosta voidaan myös tarvittaessa poistaa tietoja. PERUS-tiedostoon ei voi enää tehdä poistoja tai lisäyksiä.

Aikaisemmin rekisteröityjen pelaajien seloluvut, pelattujen selo-pelien määrät ja lisenssitiedot voidaan päivittää

Tasaselo-sivustolta haetun uuden selolistan (selolist.txt) tiedoilla.

Turnaus voidaan myös aloittaa alusta uudelleen, jolloin pelaajamuutoksia pääsee tekemään. Muutokset kohdistuvat tällöin

PELAAJAT-tiedostoon. Turnauksen uusi aloitus tuhoaa mahdollisesti jo pelattujen kierrosten kaikki tiedot, ja turnaustiedostot

pitää luoda uudestaan.

Uudelleen aloitus tulee kyseeseen vain ensimmäisen kierroksen yhteydessä.

Myös TasaseloW-ohjelmaa testatessa sitä voi käyttää.


Pelaajatietojen kopiointi

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Pelaajatiedot voidaan kopioida jostain olemassa olevasta turnauksesta.

Pelaajatietojen kopiointimahdollisuus on otettu mukaan vain ohjelman kokeilu- ja testaustarkoituksia varten.


Selolistalta

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Pelaajatietojen ilmoittaminen Selolista avulla.

Ennen Selolistalta tapahtuvaa rekisteröintiä pitää Selolista (selolist.txt) kopioida siihen hakemistoon,

missä turnauksen muutkin tiedostot sijaitsevat. Selolista on kopioitavissa Tasaselosivustolta (www.shakki.net/tasaselo).

Haku on kerran tehtävä toimenpide.

Tuorein Selolista pyritään pitämään aina saatavilla Tasaselo-sivustolla.

Lista muokataan automaattisesti TasaseloW-ohjelman käyttöön aina, kun rekisteröintiä aletaan tehdä.

Lomakkeen yläosassa olevaan hakukenttään annetaan sukunimen alusta muutama merkki. Haku käynnistyy Enter-painikkeella.

Ohjelma hakee hakukentän alla olevaan listaan kaikki hakuehdot täyttävät pelaajat, kuitenkin enintään sata kappaletta.

Haku-kenttään voidaan myös antaa koko sukunimi ja välilyönillä erotettuna etunimen alusta muutama kirjain.

Jos joku listassa näkyvä pelaaja halutaan mukaan turnaukseen, kyseinen pelaajarivi merkataan joko hiiren painikkeella tai

näppäimistön avulla. Tämän jälkeen pelaaja siirretään alempaan luetteloon joko hiiren kaksoispainalluksella tai painikkeen

Siirrä valitun... avulla.

Jos alempaan luetteloon tuotu pelaaja (tai useampi) halutaan poistaa ennen tallennusta, merkitään vastaava rivi (rivit),

ja painetaan Poista valitut -painiketta.

Pelaajatiedot siirtyvät PELAAJAT-tiedostoon vain Tallenna-painalluksen jälkeen.

Ohjelma ilmoittaa lisäyskerran pelaajamäärän ja rekisterissä olevien pelaajien määrän ponnahdusikkunaan tallennuksen jälkeen.


Pelaajatietojen kysely

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Pelaajatiedot voidaan antaa myös yksitellen, esimerkiksi silloin kun palaajaa ei löydy Selolistalta.

Syöttökenttiin annetaan vastaavat tiedot kuin pelaajista on Selolistallakin.


Pelaajatietojen listaus

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Pelaajatietojen listauksessa on huomattava, että listaus tehdään tilanteen mukaan eri tiedostoista.

Jos turnauksen kaikkia tiedostoja ei vielä ole muodostettu, tehdään listaus PELAAJAT-tiedostosta. Tämä on

aputiedosto, johon pelaajien tiedot ilmoittautumisvaiheessa talletetaan. Tähän listaukseen voidaan myös kohdistaa

muutoksia siten, että siitä voidaan poistaa pelaajia.

Jos turnauksen kaikki tiedostot on jo perustettu, tehdään listaus PERUS-tiedostosta, joka on muodostettu

kohdassa Tiedostojen alustus. Tässä vaiheessa ei tietoihin voida enää tehdä muutoksia.

Jos pelaajatietoihin vielä halutaan tehdä poistoja tai lisäyksiä, se on mahdollista aloittamalla turnauksen käsittely uudestaan.

Tämä menettely tulee kyseeseen kilpailun alkuvaiheessa, jos huomataan tiedostojen perustamisen jälkeen, tai mahdollisesti

vasta ensimmäisen kierroksen parien muodostuksen jälkeen, että pelaajistosta vielä puuttuu joku tai siellä on joku liikaa.


Selotietojen paivitys

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Jos pelaajat on rekisteröity käyttäen vanhentunutta Selolistaa, voidaan pelaajien seloluvut, pelimäärät ja lisenssitiedot

päivittää Tasaselo-sivustolta haetun uuden Selolistan avulla.

Tiedot päivittyvät ensin PELAAJAT-tiedostoon, ja jos turnauksen muut tiedostot on jo ehditty perustaa, päivittyy PERUS-tiedosto

ja alkuselojen osalta TULOS-tiedosto.

Päivitys kohdistetaan nimi- ja seuratietojen avulla.

Jos pelaajan nimi- tai seuratiedoissa on tapahtunut muutos, ei päivitystä pystytä kohdistamaan.

Näissä tapauksissa päivitys pitää tehdä MUUT TOIMET -osion korjaustoimenpiteillä.


Turnauksen uudelleenaloitus

TasaseloW ›› Perustoimet ›› Ilmoittautuminen ››

Turnaus voidaan saattaa niin haluttaessa alkutilaan, mutta tällöin kaikki jo mahdollisesti pelattujen kierrosten

tiedot menetetään. Sen sijaan kaikki PELAAJAT-tiedostoon talletetut tiedot säilyvät.

Uudelleen aloitus on tarkoitettu lähinnä erikoistilanteisiin, jotka liittyvät kilpailun käynnistämiseen.

Esimerkiksi jos huomataan, että pelaajistoon on vielä tehtävä muutoksia ensimmäisen kierroksen parien

muodostamisen jälkeen, päästää uudelleen aloitus tekemään tarvittavat muutokset, eli uusia pelaajia

voidaan ottaa mukaan ja vastaavasti voidaan pelaajia poistaa.

Pelaajamuutosten jälkeen on turnaustiedostot perustettava ( ja alustettava) uudestaan.

Jos turnauksessa on tarkoitus käyttää oletuksesta (100) poikkeavaa kerrointa, on se myös ilmoitettava uudelleen.

Jos yksittäisen pelaajan tiedoissa on korjattavaa, pitää muutokset tehdä

osion MUUT TOIMET JA LOPPUTULOKSET kautta.


Tiedostojen perustaminen

TasaseloW ›› Perustoimet ››

Kun turnaukseen osallistuvien pelaajien tiedot on rekisteröity, perustetaan ja alustetaan kaikki

TasaseloW-ohjelman käyttämät muut tiedostot.

Turnaustiedostot ovat niin sanottuja suorasaantitiedostoja, joita VisualBasicin luku- ja kirjoituskäskyt

osaavat käsitellä. Mitään tietokantaohjelmaa ei tiedostojen hallintaan tarvita.

Tietoa turnauksessa pelattavasta kierrosmäärästä tarvitaan tiedostojen alustuksessa.

TasaseloW-ohjelmassa on 200 pelaajan ja 15 kierroksen rajoitukset.

Tiedostojen alustuksessa on otettu huomioon se, että pelaajamäärä saa kasvaa kymmenellä turnauksen aikana.

Kuitenkin on harvinaista, että turnauksen käynnistyttyä mukaan otetaan paljon uusia pelaajia myöhemmille kierroksille.

Jos pelaajan seloluku puuttu tai pelimäärä on nolla, käytetään pelaajalle tiedostojen alustuksessa lukua 1525.


Ohjelman parametrit

TasaseloW ›› Perustoimet ››

Ohjelman suoritukseen liittyy joukko parametreja.

Muuttuvien vahvuuslukujen laskennassa käytetään kerrointa, joka voi vaihdella välillä 20-300. Oletusarvo on 100.

Pistelaskutapa voidaan valita kahdesta vaihtoehdosta

1. voitosta saa yhden pisteen, tasapelistä puoli pistettä ja häviöstä nolla pistettä

2. voitosta saa kolme pistettä, tasapelistä yhden pisteen ja häviöstä nolla pistettä.

Väriehto on oletusarvoisesti valittuna, jolloin värien tasaiseen vaihtumiseen kiinnitetään erityistä huomiota.

Jos väriehto ei ole valittuna, ei värihistorialla ole merkitystä, ja tällöin pelaaja saa vastustajakseen ensimmäisen vapaan pelaajan,

jonka vahvuusluku on mahdollisimman lähellä.

Jos testausasetus valitaan, näytetään joitan tietoja enemmän parien muodostamisesta, ja pelien tulosten ilmoittamisessa

fokus siirtyy automaattisesti seuraavaan pariin.

Laskentakertoimen muutos ja pisteiden laskutapa säilyvät turnauksen ohjaustiedoissa, vaikka ohjelman suoritus välillä

lopetetaan. Sen sijaan väriehdon ja testausasetuksen muutokset säilyvät vain istunnon ajan.

Ohjaustietoja voidaan muutta milloin tahansa turnauksen aikana.


Ryhmäjaon muodostaminen

TasaseloW ›› Perustoimet ››

Pelaajat jaetaan palkintoryhmiin.

Kunkin ryhmän viimeinen pelaajarivi merkataan hiiren painalluksella, alimman ryhmän viimeistä pelaajaa ei välttämättä

tarvitse merkata. Suositus on, että ryhmien koot olisivat melko saman suuruisia, ja että koko olisi noin kaksi kertaa

pelattava kierrosmäärä.

Ryhmäjakoa voi muuttaa milloin tahansa turnauksen ollessa jo käynnissä.

Tulosteissa noudatetaan ilmoitettua ryhmäjakoa.

Ryhmäjako ei vaikuta parien muodostamiseen.


Kierroskohtaiset toimet

TasaseloW ››

Kierroskohtaisissa toimenpiteissä hoidetaan kaikki yksittäiseen kierrokseen liittyvät tehtävät. Pelaajien läsnä oloon liittyvät

muutokset ovat mahdollisia ennen uusien parien muodostamista. Esimerkiksi uusi pelaaja voidaan ottaa turnaukseen mukaan.

Ohjelma edellyttää, että kierroksen pelaajamäärä on aina parillinen. Uuden pelaajan mukaan tulo tarkoittaa siis sitä,

että joku toinen pelaaja pitää vapaakierroksen tai on keskeyttänyt turnauksen.

Pelaajia ei kuitenkaan voi lisätä turnaukseen rajattomasti. Alustuksessa varaudutaan vain kymmenen uuden pelaajan

mukaan tuloon.

Parien muodostamisen jälkeen tulostetaan pariluettelo ja pöytälaput.

Päättyneiden pelien tulokset tallennetaan ohjelmaan, ja kierroksen tilanne voidaan tulostaa.

Myös automaattisesti päivittyvä tulosseuranta voidaan käynnistää, ja jos käytettävissä on lisämonitori

(tai projektori), tulosseuranta voidaan jättää pyörimään siihen.


Pelaajamuutokset

TasaseloW ›› Kierroskohtaiset toimet ››

Pelaajatietojen muutoksilla ilmoitetaan pelaajien mukana- tai poissaolo seuraavalla kierroksella. Tässä on huomattava,

että muutokset tehdään seuraavan kierroksen parien määräämistä varten. Uusi pelaaja voidaan ottaa mukaan, pelaaja

voi olla poissa kierrokselta, pelaaja voi keskeyttää turnauksen tai pelaaja voi tulla uudestaan mukaan turnaukseen.

Pelaajan ilmoittaminen vapaakierrokselle (huilikierros) kestää vain tulevan kierroksen verran, ja hän palaa automaattisesti

mukaan myöhemmille kierroksille.

Seuraavalle kierrokselle siirtyminen tulee mahdolliseksi vasta, kun valikon alimmalla vaihtoehdolla ilmoitetaan,

että pelaajamuutoksia ei enää tehdä.


Uusi pelaaja mukaan

TasaseloW ›› Kierroskohtaiset toimet ›› Pelaajamuutokset ››

Kesken turnauksen mukaan tuleva pelaaja pitää rekisteröida kyselynäytön avulla.

Pelaaja pitää ilmoittaa mukaan johonkin olemassa olevaan ryhmään (1,2,---).


Pelaaja huilaa

TasaseloW ›› Kierroskohtaiset toimet ›› Pelaajamuutokset ››

Pelaaja voidaan ilmoittaa huilaajaksi (vapaakierros) jollekin kierrokselle. Huilaus kestää oletusarvosesti vain yhden

kierroksen ajan, ja pelaaja on automaattisesti mukana seuraavilla kierroksilla.

Huilauskierrokselta pelaaja saa puoli pistettä.

Jos kilpailussa on sallittua aloittaa toiselta kierrokselta, pitää pelaaja kuitenkin rekisteröidä mukaan, mutta hänet merkataan

huilaajaksi ennen ensimmäisen kierroksen parien määräämistä.


Pelaaja keskeyttää

TasaseloW ›› Kierroskohtaiset toimet ›› Pelaajamuutokset ››

Pelaaja voi keskeyttää turnauksen ennen seuraavan kierroksen parien muodostamista.

Keskeyttäneen pelaajan tilalle on rekisteröitävä varapelaaja, tai joku toinen pitää huilivuoron.

Jos varapelaajaa ei ole käytettävissä, voidaan turnaukseen ilmoittaa mukaan niin sanottu haamupelaaja.

Haamupelaajalle annetaan selvästi pienempi vahvuusluku kuin mukana olevilla pelaajilla.

Näin alimman ryhmän loppupään pelaajista joku saa vastustajakseen haamupelaajan eli käytännössä vapaavuoron.


Pelaaja palaa

TasaseloW ›› Kierroskohtaiset toimet ›› Pelaajamuutokset ››

Keskeyttänyt pelaaja voi uudelleen tulla mukaan turnaukseen,

tai huilivuoro voidaan perua ennen parien muodostamista.


Ei muutoksia Uusi kierros

TasaseloW ›› Kierroskohtaiset toimet ›› Pelaajamuutokset ››

Ennen kuin seuraavan kierroksen parit voidaan muodostaa,

pitää 'Pelaajamuutokset'-valikon alin kohta 'Ei muutoksia Uusi kierros' olla valittuna.


Parien muodostus

TasaseloW ›› Kierroskohtaiset toimet ››

Parien muodostaminen merkitsee siirtymistä seuraavalle kierrokselle, ja parit voidaan muodostaa vasta, kun Pelaajamuutokset-valikon alin kohta 'Ei muutoksia Uusi kierros' on valittu. Tällöin myös kierroslaskuri saa uuden arvon. Kaikki pelaajamuutokset siis tehdään tätä uutta kierrosta varten.

Parien modostamisessa etsitään kullekin pelaajalle vastustaja, jonka laskennallinen vahvuusluku (muuttuva selo) on mahdollisimman lähellä. Parillisilla kierroksilla huolehditaan myös siitä, että kaikki tulevat pelanneiksi yhtä monta kertaa valkeilla ja mustilla väreillä.

Parien etsiminen etenee siten, että ensinnä haetaan korkeimman vahvuusluvun pelaajalle pari, sitten alimman luvun pelaajalle, sen jälkeen taas vahvuusjärjestyksessä korkeimmalle vapaalle pelaajalle ja niin edelleen. Etsiminen siis etenee vuoron perään alusta ja lopusta päin.

Jos pelaajamuutoksia on ollut turnauksessa paljon, ei väriehtoa aina pystytä toteuttamaan.

Eteen voi myös tulla tilanne, että parien muodostaminen edellyttää lisää pelaajamuutoksia. Sellaiset tilanteet ovat kuitenkin äärimmäisen harvinaisia, jos turnauksen pelaajamäärä on noin kaksi kertaa kierrosmäärän suuruinen. Ongelmia voi esiintyä oikeastaan vain silloin, jos tapahtuu paljon keskeyttämisiä ja uusien pelaajien mukaan tuloja, tai jos turnauksen kierrosmäärä on vain hieman pelaajamäärää pienempi.


Kierroksen tulosteet

TasaseloW ›› Kierroskohtaiset toimet ››

Kierroskohtaisia tulosteita on kolme kappaletta.

  1. Parilista
  2. Pöytälaput
  3. Tilannetaulukko

Tulosteissa esiintyvät pelaajien seurojen nimet on rajoitettu kahdeksaan merkkiin.

Ohjelma tekee tarvittavan lyhentämisen automaattisesti.

Parilistassa on luettelo kierroksen pareista.

Pöytälaput sisältävät tietoja aikaisemmilta kierroksilta, ja parien muodostukseen vaikuttaneita tietoja.

Tarkoitus on, että pöytälaput jaetaan pöytiin ennen kierroksen alkua,

ja että pelajat merkitsevät lopputuloksen pelin päätyttyä pöytälappuun ja toimittavat sen turnausjärjestäjälle.

Tilannetaulukossa on ajantasainen tilanne ryhmittäin. Pelaajat ovat pistemääriensä mukaisessa järjestyksessä.

Jos pelaajistoon kuuluu paljon uusia pelaajia, joiden vahvuusluku on arvioitu tai asetettu oletusarvoon 1525,

voi tilannetaulukon järjestys olla hiukan erilainen kuin lopputuloksissa.

Lopputuloksissa käytetään vertailulistan teossa laskettuja uusia vahvuuslukuja,

jolloin vastustajien keskivahvuus voi muodostua erilaiseksi kuin tilannetaulukossa.


Parilista

TasaseloW ›› Kierroskohtaiset toimet ›› Kierroksen tulosteet ››


Pöytälaput

TasaseloW ›› Kierroskohtaiset toimet ›› Kierroksen tulosteet ››

Pöytälappujen tulostuksessa huolehditaan ohjelmallisesti siitä, että lappujen eri sivuille jakautuminen tapahtuu pöytälappujen vaihtumiskohdassa. Normaalisti yhdelle sivulle mahtuu yhdeksän lappua.

Pöytälapun tiedot:
Lapun parilla ensimmäisellä rivillä on valkeilla ja mustilla pelaavien nimi- ja seuratiedot, sekä parin numero.
Kohdassa Selo: on pelaajan vahvuusluku ennen kilpailua. Kohdassa Muuttuva selo: on se laskennallinen vahvuusluku, jota on käytetty parien muodostuksessa.
Kohdassa Keskivastus: on pelaajan vastustajien alkuselojen keskiarvo. Kohdassa odotus: on laskennallinen pistemäärä, joka pelaajan tulisi saavuttaa kyseisen kierroksen jälkeen, jotta hänen vahvuuslukunsa pysyisi ennallaan. Luku siis perustuu yleisiin seloluvun laskennan sääntöihin.
Seuraavalla rivillä (tai riveillä) on tiedot pelaajan eri kierroksilla pelaamista otteluista (vastustajan numero ja tulos kyseisestä pelistä: + voitto, - häviö, = tasapeli).
Alimmalla rivillä on pelaajan saavuttama pistemäärä ennen viimeisintä kierrosta.


Tilannetaulukko

TasaseloW ›› Kierroskohtaiset toimet ›› Kierroksen tulosteet ››

Tilannetaulukon sarakkeilla on pelaajan alkuselo, kierroksittaiset tulokset, saavutettu pistemäärä, vastustajien keskivahvuus, saavutetun ja odotustuloksen erotus päättyneistä peleistä, ja pelaajan muuttuva selo parien määräämistä suoritettaessa.
Pelaajien järjestys listalla, pistemäärä ja tulos-odotustulos päivittyvät sitä mukaa, kun pelien tuloksia tallennetaan.

Järjestys määräytyy kilpailuryhmän, saavutetun pistemäärän ja vastustajien alkuseloihin perustuvan keksivahvuuden mukaan, ja ei siis välttämättä ole sama, kuin kierroksen jälkeen muodostettavissa olevilla vertailulistalla ja lopputulosten listalla.


Ajantasainen tulospalvelu

TasaseloW ›› Kierroskohtaiset toimet ››

Ajantasainen tulospalvelu on tarkoitettu toimimaan jatkuvasti päällä olevana. Se käyttää samoja tietoja, jotka ovat myös tilannetaulukossa, ja tiedot päivittyvät aina, kun tietojen syöttölomakkeella klikataan Tallenna-painiketta.

Jos käytettävissä on toinen monitori (tai projektori), voidaan ajantasainen tuloste näyttää siinä.

Jos turnauksessa on enemmän ryhmiä kuin näytölle kerralla mahtuu, voidaan tuloste määritellä vieritettäväksi joko riveittäin tai ryhmittäin. Vieritysnopeutta voidaan haluttaessa jonkin verran muuttaa.


Tulosten ilmoittaminen

TasaseloW ›› Kierroskohtaiset toimet ››


Korjaukset ja Lopetustoimet

TasaseloW ››

Tässä osiossa voidaan tehdä korjauksia pelaajien tietoihin tai aikaisempien kierrosten virheellisiin väri- ja/tai tulostietoihin.

Korjaustoiminnossa ei pelaajaparin värien vaihtaminen automaattisesti muuta parin tulostietoa. Tulostieto on siis tarvittaessa

vaihdettava erikseen.

Mahdollista on myös lisätä turnaukseen uusi kierros, jos turnauksen perustamisvaiheessa ilmoitettua kierrosmäärää halutaan kasvattaa.

Lopetustoimenpiteisiin kuuluvat vertailulistan muodostus ja lopputilanteen tulostus.

On mahdollista tulostaa minkä tahansa kierroksen jälkeen vertailulista ja lopputulosten lista, vaikka kilpailun kierrosmäärä ei olisi vielä täyttynyt. Vertailulista voidaan sen lisäksi tehdä mielivaltaiselta kierrokselta.

Lopputilannetta ei voi tulostaa ennen kuin kierroksen jälkeinen vertailulista on muodostettu.

Lopputulosten muodostuksen yhteydessä tehdään möys tekstitiedosto, joka on tarkoitettu kopioitavaksi Tasaselon Internet-sivustolle. Tarkempi kuvaus tiedostosta löytyy kohdasta Lopputulokset.


Korjaukset

TasaseloW ›› Korjaukset ja Lopetustoimet ››

Sekä pelaajien että turnauksen tietoja voidaan korjata.

Turnaukseen voidaan myös lisätä uusi kierros.

Turnaus voidaan lopettaa ennen aiottua kierrosmäärää, ja lopputulokset voidaan tulostaa minkä tahansa kierroksen jälkeen.

Vertailulista on mahdollista tulostaa myös jostain aikaisemman kierroksen jälkeisestä tilanteesta.
Lopputulokset voidaan tulostaa vain viimeiseksi pelatun kierroksen jälkeen, mutta turnaus voidaan lopettaa minkä kierroksen jälkeen tahansa. Esimerkiksi seitsemänkierroksiseksi alustettu turnaus voidaan lopettaa kierrokseen kuusi.


Turnausotsikon korjaus

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Korjattu tieto kirjoitetaan entisen tilalle.

Turnausotsikolle on varattu tilaa 50 merkkiä.


Pelaajatietojen korjaus

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Valitaan listasta pelaaja, jonka tietoja halutaan muuttaa. Kyselylomakkeella annetaan korjatut tiedot. Korjattu tieto päivittyy uusiin tulosteisiin.


Aikaisemman kierroksen väri- ja/tai tulostietojen korjaus

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Annetaan sen kierroksen numero, jolla olevia virheellisiä väri- tai tulostietoja halutaan muuttaa.

Ilmoitetun kierroksen tulokset saadaan tulostenilmoituslomakkeelle.

Tämän jälkeen avautuu samanlainen lomake, millä kierroksittaisetkin tulokset ilmoitetaan.

Samalla voidaan korjata useamman pelin tietoja.

Huomattava on, että tulosilmoituslomakkeelle ei voi lisätä uutta paria.


Parien muodostaminen uudestaan

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Pelaajatietojen tai tulosten korjailun jälkeen viimeisimmän kierroksen parit voidaan muodostaa uudestaan.

Tässä yhteydessä ei siis päästä tekemään pelaajien läsnä oloon turnauksessa liittyviä muutoksia.

Jos on tarve uusia parit siten, että myös pelaajamuutoksia halutaan tehdä,

pitää kyseisen kierroksen tiedot ensin mitätöidä.


Viimeisimmän kierroksen mitätöinti

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Käsittelyssä olevan (viimeisimmän) kierroksen kaikki tiedot voidaan poistaa. Turnauksessa siirrytään yhden kierroksen verran taaksepäin, ja seuraavaa kierrosta koskevia pelaajamuutoksia päästään tekemään.

Tällä menettelyllä on mahdollista tehdä osallistumistietoihin muutoksia,

vaikka käynnissä olleen kierroksen pareihin liittyviä tuloksiakin olisi jo ehditty antaa.
Kierroksen mitätöinti on kuitenkin harvinainen poikkeustilanne, joka tulee eteen oikeastaan vain silloin, kun joku pelaaja on yllättäen keskeyttänyt, eikä ole siitä turnausjärjestäjälle kertonut. Mitätöimällä kierroksen tiedot, tekemällä tarvittavat pelaajamuutokset ja muodostamalla sitten parit uudestaan, vältetään se, ettei kukaan pelaaja joudu pitämään ennakoimatonta vapaakierrosta.

On myös mahdollista jättää kierroksen parien uusinta tekemättä, ja merkata pois jääneen pelaajan peli luovutetuksi.


Lisätään turnaukseen uusi kierros

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Korjaukset ››

Turnaukseen on mahdollista lisätä uusi kierros, jos turnaus halutaan useampikierroksiseksi,

mitä alun perin perustamisvaiheessa on ilmoitettu.

Suositeltavaa on kuitenkin, että perustamisvaiheen jälkeen kierrosmäärä ei enää kasvateta.


Lopputulokset

TasaseloW ›› Korjaukset ja Lopetustoimet ››

Ennen kuin lopputulokset on mahdollista tulostaa, on muodostettava vertailulista. Vertailulistaa ei voida muodostaa, ennen kuin kyseisen kierroksen kaikki tulostiedot on tallennettu.


Vertaililista

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Lopputulokset ››

Vertailulista on modostettava ennen kuin turnauksen lopputuloksia voidaan tulostaa. Vertailulista voidaan ajaa haluttaessa jostain aikaisemmasta kierroksesta, mutta lopputuloksiin vaikuttava vertailu on ajettava viimeisimmän kierroksen tiedoista.

Vertailulistan teossa on mahdollista käyttä monia vertailutekijöitä. Vertailussa käytetään kolmea sisäkkäistä perustetta.

Oletusarvoisesti pääjärjestyksen muodostaa kilpailuryhmä, sen sisällä järjestys määräytyy saavutetun pistemäärän perusteella,

ja saman pistemäärän saaneet pelaajat asetetaan järjestykseen vastustajien keskivahvuuden mukaan.

Jos pelaajan pelattujen pelien määrä on nolla tai seloluku puuttuu, käytetään uusien selojen laskennassa oletusarvoa 1525.

Kussakin ryhmittelyssä voidaan käyttää kuutta eri tekijää. Nämä ovat:

Palkintoryhmä

Pistetulos

Suoritusluku

Vasustajien keskivahvuus

Tulos-odotustulos

Buchholz (eli vastustajien saavuttamien pistemäärien summa)

Kilpailussa käytetty peliaika vaikuttaa uusien selojen laskentaan siten, että laskennassa käytetään erilaisia kertoimia.

Turnauksessa on mahdollista käyttää erilaisia peliaikoja eri kierroksilla, kuitenkin niin, että muutoksen voi tehdä vain kerran.

Esimerkiksi kierroksilla 1-3 voidaan käyttää nopean shakin peliaikoja, ja kierroksilla 4-5 normaalishakin peliaikoja.

Jos koko turnaus on pelattu käyttäen vain yhtä peliaikaa, ruksataan vastaava kohta valintanäytöllä.

Tällöin ei näytön kierrostietoja oteta lainkaan huomioon.


Vertailulistan malli

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Lopputulokset ››


Lopputulokset

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Lopputulokset ››

Kun vertailulista on muodostettu, voidaan tulostaa turnauksen lopputulokset.

Lopputulosten järjestys määräytyy vertailulistan perusteella.

Lopputulosten ohessa luodaan myös tiedosto Tasaselo-sivustoa varten,

jossa on yhdistetty lopullisen tulostaulukon ja vertailulistan tiedot.

Tiedoston nimi on standardoitu muotoon
tttvkkpp.txt,
missä ttt on turnauksen kolmemerkkinen tunnus, v on vuosiluvun viimeinen numero, kk on tulostuspäivän kuukausi ja pp on tulostuksen kuukaudenpäivä.

Esimerkiksi jos turnaus RNF on pelattu 21.3.2015, on tiedoston nimi RNF50321.txt.
Huomattava on, että tiedoston nimen päivämäärätieto perustuu tiedoston luontipäivään.

Yleensä se tietenkin on sama kuin kilpailun lopetuspäivämäärä.

Tasaselo-sivustolla oletetaan, että tiedoston nimessä on nimenomaan kilpailun lopetuspäivä.
Jos tiedosto on siis muodostettu jonakin muuna päivänä, on tiedoston nimi muutettava ennen Tasaselo-sivustolle vientiä.


Lopputulosten malli

TasaseloW ›› Korjaukset ja Lopetustoimet ›› Lopputulokset ››


Ongelmia ja ratkaisuja

TasaseloW ››

Tähän on koottu joitain tyypillisimpiä ohjelman käytössä eteen tulleita ongelmia,
ja niihin ehdotettuja ratkaisuja.


Muutos pelaajistoon

TasaseloW ›› Ongelmia ja ratkaisuja ››

Melko usein käy niin, että pelaajistossa huomataan virhe vasta siinä vaiheessa, kun ensimmäisen kierroksen parit on jo ehditty muodostaa. Joku pelaaja on saattanut jäädä rekisteröimättä, joku ennakkoon ilmoittautunut ei olekaan saapunut, mutta on vielä pelaajistossa, tai pelaajistoon on rekisteröity väärä henkilö.

Ratkaisuehdotus:

Paras tapa on keskeyttää mahdollisesti jo käynnistetty ensimmäinen kierros, vaikkakin se hiukan viivästyttää kilpailun alkua. Sen jälkeen valitaan Perustoimet-osion valikosta Ilmoittautuminen... kohta 'Turnauksen uusi aloitus'. Tällöin päästään tekemään muutoksia pelaaja-rekisteriin.
Uudella aloittamisella on se vaikutus, että pelaajien tiedot haetaan tämän jälkeen PELAAJAT-tiedostosta, joka on aputiedosto, jonne pelaajatiedot ilmoittautumisvaiheessa talletetaan.
Ilmoittautuminen... -valikon Pelaajatietojen selaus -kohta näyttää tiedot nyt niin, että poistot ovat mahdollisia.
Jos uusi pelaaja halutaan viedä rekisteriin, se tapahtuu joko Selolistalta... tai Kysellen.. -kohtien kautta.
Muutosten jälkeen pitää muistaa Tallenna-painallus ennen poistumista.

Seuraavaksi pitää turnaustiedostot alustaa uudelleen.
Jos käytetään oletuksesta (100) poikkeavaa kerrointa, se on myös annettava uudestaan.

Näiden muutosten jälkeen muodostetaan ensimmäisen kierroksen parit normaalilla tavalla.


Aloitukset toiselta kierrokselta

TasaseloW ›› Ongelmia ja ratkaisuja ››

Jos on sallittua aloittaa turnaus toiselta kierrokselta, pitää tällaiset pelaajat kuitenkin rekisteröidä mukaan kilpailun pelaajistoon normaalilla tavalla.

Ennen ensimmäisen kierroksen parien määräämistä merkataan toiselta kierrokselta aloittavat pelaajat huilaajiksi, jolloin heille ei määrätä paria ensimmäiselle kierrokselle.

Huilauskierroksen jälkeen pelaaja tulee automaattisesti mukaan seuraaville kierroksille.

Huilauskierros tuottaa pelaajalle puoli pistettä.